読者です 読者をやめる 読者になる 読者になる

まめ畑

ゆるゆると書いていきます

rvmで入れたRubyとVimのビルド

homebrew Ruby vim

homebrewでVimを入れて、Upgradeしようとしたら、Vimのmakeで以下のエラーを出してコケたので解決方法をメモ。

ld: library not found for -lruby.1.9.1
collect2: ld returned 1 exit status
make[1]: *** [vim] Error 1
make: *** [first] Error 2
==> Build Environment
CPU: quad-core 64-bit sandybridge
MacOS: 10.7.3-x86_64
Xcode: 4.3.1
CC: /usr/bin/llvm-gcc => /usr/llvm-gcc-4.2/bin/llvm-gcc-4.2
CXX: /usr/bin/llvm-g++ => /usr/llvm-gcc-4.2/bin/llvm-g++-4.2
LD: /usr/bin/llvm-gcc => /usr/llvm-gcc-4.2/bin/llvm-gcc-4.2
CFLAGS: -Os -w -pipe -march=core2 -msse4
CXXFLAGS: -Os -w -pipe -march=core2 -msse4
MAKEFLAGS: -j4
Error: Failed executing: make (vim.rb:21)
If `brew doctor' does not help diagnose the issue, please report the bug:
    https://github.com/mxcl/homebrew/wiki/checklist-before-filing-a-new-issue

結論としては、rvmで入れたRubyだと発生する模様。Vimを最初に入れた時はまだrvm入れる前だったので上手くいったみたい。system Rubyを使えということなのかな。
なので、

rvm system
brew upgrade vim
rvm use 1.9.3-head

これで大丈夫